Neu! – idealo für WooCommerce – Das offizielle idealo Plugin!

PHP 7.2+ Update

idealo für WooCommerce-Updates unterstützen keine PHP-Versionen unter 7.2 – wir empfehlen, PHP auf Version 7.2 oder höher zu aktualisieren.

Warum ist es notwendig PHP zu aktualisieren?

Die Hauptgründe, warum PHP auf eine aktuelle Version aktualisiert werden sollte, sind Sicherheit, Kompatibilität und Performance.

Viele Plugins für WordPress haben heutzutage bereits höhere PHP-Anforderungen und auch WordPress und WooCommerce empfehlen bereits höhere Versionen als Minimum (WordPress 7.4 https://wordpress.org/about/requirements/, WooCommerce 7.3 https://docs.woocommerce.com/document/server-requirements/), um Sicherheit und Funktionalität zu gewährleisten.

Webseiten mit einer veralteten PHP-Version können anfällig für Angriffe sein oder einfach durch ein Software-Update, das nicht mehr mit der veralteten PHP-Umgebung kompatibel ist, abstürzen.

Ein Update der PHP-Version macht die Systeme nicht nur sicherer und stabiler, sondern verbessert oft auch die Geschwindigkeit von Websites, da Versionen höher als 7.2 effizienter in Bezug auf die Leistung sind.

Wie PHP updaten?

PHP-Versionen werden vom Hoster verwaltet. Bei Unsicherheit darüber, wie ein PHP-Update sicher durchgeführt wird, oder wenn die Aktualisierungsoptionen nicht über das Backend zugänglich sind, lesen empfehlen wir die Dokumentationen des Hosters danach zu durchsuchen, wie PHP ordnungsgemäß aktualisiert wird.

Wenn keine Dokumentation verfügbar ist oder immer noch Unsicherheit herrscht, empfehlen wir, sich an den Support des Hosters zu wenden und um Unterstützung zu bitten.

Achtung: Die Aktualisierung von PHP kann ein riskantes Verfahren sein und zu Datenverlust führen, wenn keine funktionierenden Backups vorhanden sind.

Was passiert mit alten PHP-Versionen?

idealo für WooCommerce wird weiterhin funktionieren, aber nicht mehr von uns unterstützt werden. Alle zukünftigen Updates werden nicht mit niedrigeren PHP-Versionen kompatibel sein. Wenn also Probleme mit idealo für WooCommerce auftreten, können wir leider keinen Support für veraltete Umgebungen leisten.

Wir empfehlen daher dringend, die PHP-Version zu aktualisieren.